Opened 9 years ago

Closed 9 years ago

#2876 closed defect (fixed)

"Map key" broken when using Icelandic in Chrome / Firefox / Opera. English works fine

Reported by: avar Owned by: Tom Hughes
Priority: major Milestone:
Component: website Version:
Keywords: Cc:

Description

The sidebar map key doesn't show anything aside from the "viewing at zoom $n" heading under Icelandic. Works fine with English.

Also works if I manually browse e.g. http://www.openstreetmap.org/key?layer=mapnik&zoom=17

Didn't spot anything in Firefox's JS console to indicate what it might be.

Change History (2)

comment:1 Changed 9 years ago by Tom Hughes

The problem is that we're pulling the layer name from the map and passing that in the URL for they key but the Icelandic translation translates the layer names so the server doesn't find any key data.

I'll have a look at getting the layer name from somewhere that isn't translated...

comment:2 Changed 9 years ago by tomhughes

Resolution: fixed
Status: newclosed

(In [20887]) Add a keyid attribute to each layer and use it when requesting the key instead of trying to use the layer name, which can be translated which will stop it working. Closes #2876.

Note: See TracTickets for help on using tickets.