Opened 9 years ago

Closed 9 years ago

#2915 closed defect (fixed)

waterway=lock chevrons have random orientation

Reported by: malcolm.herring@… Owned by: osm@…
Priority: minor Milestone:
Component: osmarender Version:
Keywords: Cc:

Attachments (3)

21109.png (9.1 KB) - added by malcolm.herring@… 9 years ago.
Tile with lock
21109b.png (9.0 KB) - added by malcolm.herring@… 9 years ago.
21109c.png (9.0 KB) - added by malcolm.herring@… 9 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by osm@…

Resolution: worksforme
Status: newclosed

That tile looks fine and the lock should always point with the pointy and towards upstream of the waterway...

comment:2 Changed 9 years ago by malcolm.herring@…

Resolution: worksforme
Status: closedreopened

Sorry, I seem to have pointed to a good one. Try this:

http://b.tah.openstreetmap.org/Tiles/tile/16/32575/21109.png

What I see is:

Downstream chevron is at right angles to way (points to bank). Upstream chevron is about 45 degrees to way.

Changed 9 years ago by malcolm.herring@…

Attachment: 21109.png added

Tile with lock

comment:3 Changed 9 years ago by malcolm.herring@…

OK, now this is wierd - that same tile now shows the upstream chevron with the correct orientation. (The downstream one is still at right angles). I will attach the PNG file rather than the link.

Changed 9 years ago by malcolm.herring@…

Attachment: 21109b.png added

comment:4 Changed 9 years ago by malcolm.herring@…

... and now it has reverted to the orientation I originally reported. See second attachment.

comment:6 Changed 9 years ago by osm@…

Hrm. That might at heart be a duplicate of #1982.

comment:7 Changed 9 years ago by malcolm.herring@…

That fits with the situation at the downstream gate, but not the upstream gate. The only ways attached to that node are in line with each other. Also, why does it change from render to render?

I have edited that downstream gate node so that the way which is at right anlges to the lock way does not have a node at that point. If the problem on that gate goes away, then that would be an example of #1982.

However, the upstream gate variable orientation would appear to be a separate problem.

Changed 9 years ago by malcolm.herring@…

Attachment: 21109c.png added

comment:8 Changed 9 years ago by malcolm.herring@…

... and that did undo the right-angle orientation, but it still is not correct. (See third file attached)

comment:9 Changed 9 years ago by petschge

Resolution: fixed
Status: reopenedclosed

(In [21673]) Make sure that lock chevrons only are oriented along k=waterway v=artificial|canal|ditch|drain|river|stream. This most importantly omits k=waterway v=riverbank. This relies on the new properties of orp introduced in the last commits and fixes #2915

Note: See TracTickets for help on using tickets.