Opened 9 years ago

Closed 9 years ago

#2919 closed defect (fixed)

Deleting node that loops way fails upload

Reported by: Toby Speight Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

  • Find a looped way (e.g. as reported my mkgmap).
  • Remove the node causing the loop (i.e. the one that appears more than once in the way)
  • Upload

You'll get an error that the deleted node is still in use, and the only useful option is to abort the entire upload (you can no longer skip the problem and return to it after upload).

I think the problem is that only the first instance is removed from the way.

Change History (1)

comment:1 Changed 9 years ago by Chris Browet

Resolution: fixed
Status: newclosed

fixed in [21036]

Note: See TracTickets for help on using tickets.