Opened 9 years ago

Closed 9 years ago

#2934 closed defect (fixed)

Many windows created during upload

Reported by: Toby Speight Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

When uploading, there seems to be one progress window per feature, resulting in lots of flickering windows appearing all over the place. Luckily, I have my window manager set to auto-place windows, but I imagine that this could be irritating (to say the least) for those using interactive placement.

I think there should be at most one progress window per upload.

Change History (3)

comment:1 Changed 9 years ago by Chris Browet

Strange... There is only only one window created (especially since I switch to diff upload, where there really is only one communication with the server)...

Could you try with a clean checkout, please...

comment:2 Changed 9 years ago by Toby Speight

Confirmed with a clean build. Stepping through in gdb shows that it's somewhere within the call to runVisit at DirtyListExecutorOSC.cpp line 152; I'll continue investigating as and when I have features to upload.

comment:3 Changed 9 years ago by tspeight

Resolution: fixed
Status: newclosed

(In [21286]) Set the correct range on the progress meter before use (fixes #2934).

Note: See TracTickets for help on using tickets.