Opened 9 years ago

Closed 9 years ago

#2952 closed defect (fixed)

Merkaartor .osm exports don't include node version=

Reported by: HamishB Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

Hi. I'm working with Merkaartor version 0.14+svnfixes~20090912-2~bpo50+1 for Debian/Lenny? from backports.org. I'm not sure if it's in 15.3 as the library req's are too new for any OS I have access to. I don't see anything in the CHANGELOG or bug trac'er about it though.

If I export some data with File -> Export -> OSM (XML), I get a nice merk.osm file. But JOSM (latest testing version r3208) refuses to open it because the version= is missing from the nodes.

thanks, Hamish

ps- running this version of Merk. with X11 tunneled over high-speed ssh to a machine down the hall with lots and lots of RAM is painfully slow. gkrellm shows that the ethernet connection is pegged at many Mbps. Any way to improve that? ( 24 fps translates to a 42ms usleep() delay )

Change History (3)

comment:1 Changed 9 years ago by Chris Browet

Will have a look.

Re dependencies, the only "hard" dependency in Qt (>=4.5.3). Could even work with 4.4.3 but I do not have a way to test that anymore. If you have access to this Qt version, just run "qmake -r USE_BUILTIN_BOOST=1 && make" and you have a recent merkaartor, with only some features disabled.

comment:2 Changed 9 years ago by Chris Browet

And please open a separate ticket for the "X11 over ssh" problem. This is definitely a separate issue...

comment:3 Changed 9 years ago by Chris Browet

Resolution: fixed
Status: newclosed

(In [21250]) FIX : Make JOSM happy about our .osm export (fixes #2952)

Note: See TracTickets for help on using tickets.