Opened 9 years ago

Closed 8 years ago

#3001 closed defect (fixed)

mod_tile's debian package can't be build without munin.

Reported by: rorym Owned by: jburgess777@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

I am installing mod_tile on an ubuntu lucid (10.04) machine. I don't have munin installed. I tried to build mod_tile (r21420) using dpkg-buildpackages and it failed with the following error message:

...
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dpkg-shlibdeps: warning: debian/libapache2-mod-tile/usr/lib/apache2/modules/mod_tile.so contains an unresolvable reference to symbol apr_ctime: it's probably a plugin.
dpkg-shlibdeps: warning: 36 other similar warnings have been skipped (use -v to see them all).
dh_gencontrol
dpkg-gencontrol: warning: unused substitution variable ${shlibs:Depends}
dpkg-gencontrol: warning: unused substitution variable ${shlibs:Depends}
dh_md5sums
dh_builddeb
dpkg-deb: building package `libapache2-mod-tile' in `../libapache2-mod-tile_0.3_i386.deb'.
dpkg-deb: building package `renderd' in `../renderd_0.3_i386.deb'.
dpkg-deb: conffile `/etc/munin/plugins/renderd_queue' does not appear in package
dh_builddeb: dpkg-deb --build debian/renderd .. returned exit code 2
make: *** [binary-arch] Error 9
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2

This is because {{{debian/renderd.conffiles}} is like this:

/etc/renderd.conf
/etc/munin/plugins/renderd_queue
/etc/munin/plugins/renderd_processed

One solution is to remove the munin stuff from that file, with the following patch:

Index: debian/renderd.conffiles
===================================================================
--- debian/renderd.conffiles	(revision 21420)
+++ debian/renderd.conffiles	(working copy)
@@ -1,3 +1 @@
 /etc/renderd.conf
-/etc/munin/plugins/renderd_queue
-/etc/munin/plugins/renderd_processed

This is what I'm using. I'm not sure what affect this will have if you are using munin, and I'm not sure if it's possible to have it work OK regardless if you're using munin. If it's not possible to remove that munin conffiles, then renderd should depend on munin.

Change History (3)

comment:1 Changed 8 years ago by Ldp

Owner: changed from mapnik-team@… to jburgess777@…
Status: newassigned

comment:2 Changed 8 years ago by brian_252

Thanks rorym. That worked for me.

comment:3 Changed 8 years ago by amm

Resolution: fixed
Status: assignedclosed

Fixed in commit r26348

Note: See TracTickets for help on using tickets.