Opened 9 years ago

Closed 5 years ago

#3013 closed defect (duplicate)

LTR & RTL rendering

Reported by: mesgary@… Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

While rendering a name which contains both LTR and RTL alphabet (English & Persian), the Persian part are rendered incorrectly. For example the name of Iran is the bellow link are rendered incorrectly.
http://www.openstreetmap.org/?lat=32.8&lon=53.9&zoom=5&layers=B000FTF
It is rendered:

)Iran( ای‌ر‌ا‌ن

while it should be

(Iran) ایران

The same problem happened for Afghanistan, Pakistan and Western Sahara!

Change History (4)

comment:1 Changed 9 years ago by mesgary@…

I should add this complementary comment: The problem I am pointing is rendering the Persian name with non-joined character. The "(" and ")" problem are considered in Bug #2946. Also this bug is not happening when it is only Persian characters!

comment:2 Changed 9 years ago by TomH

Mapnik ticket 189 (http://trac.mapnik.org/ticket/189) will still be the underlying cause however - this is not a bug in our mapnik stylesheets, it's a bug in the mapnik software.

comment:3 Changed 8 years ago by jahudie@…

Just wanted to point out that of course this is not only a problem for Iran, Afghanistan, Pakistan but also in Israel.

We experiencing this issue for a long while, too.

Here a example: http://www.openstreetmap.org/?lat=32.781649&lon=34.961071&zoom=18&layers=M

Its really time to solve it.

comment:4 Changed 5 years ago by Andy Allan

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2946

Note: See TracTickets for help on using tickets.