Opened 9 years ago

Closed 8 years ago

#3020 closed defect (wontfix)

Improve rendering of bridges, tunnels and layers

Reported by: stanton Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

When a bridge goes over another road and the bridge is very short, rendering is somewhat unfortunate: At lower zoom levels, at which road widths are overdrawn, the bridge appears not to span the road underneath (in some cases, the road underneath may even be drawn on top of the road parts which do not have the bridge attribute). In some cases the two roads appear to be connected when in fact they are not.

The same problem may affect tunnels or any use of the layer tag. It is caused by the fact that the width of a road is technically zero but it is rendered at a nonzero width. At low zoom levels road widths are overdrawn (the road is drawn wider than it is in nature so that it is still visible). If bridges tagged the correct way (with only the part that is in the air tagged as bridge=yes), they are in fact shorter than the road they cross.

Solution approach: If a bridge crosses any way which will be rendered with a width greater than zero, extend it to completely cover any way which passes underneath it (and possibly a few pixels further for better visibility). Similar rules can be applied to tunnels and ways with layer tags set.

As for tunnels, adding a black line representing the tunnel portal would make tunnels easier to identify.

Change History (1)

comment:1 Changed 8 years ago by Ldp

Resolution: wontfix
Status: newclosed

While you have good points here, it's not something that's within the capabilities of the renderer. As such, I have to close this as wontfix. I'm not aware of any development in this area, which makes render support of this capability at least years into the future.

Note: See TracTickets for help on using tickets.