Ticket #3022 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

json_callback doesn't accept javascript function names with dots

Reported by: heb Owned by: geocoding@…
Priority: major Milestone:
Component: nominatim Version:
Keywords: JSON, JSON-P Cc:

Description

I'm using MooTools? More's 1.2 Request.JSONP class for retrieving reverse geocoded location data. For assiging JSON-P requests to actual mootools request callbacks (e.g. onSuccess) the mootools class uses a mapper function (Request.JSONP.request_map.request_0). The problem is that nominatim ignores the value of the json_callback GET-parameter if this value contains one or more periods. In effect the nominatim json search doesn't work the MooTools?' build-in way - as a workaround I had to define my own function (without periods), which breaks the elegant classes concept of MooTools?.

Change History

comment:1 Changed 2 years ago by TomH

  • Owner changed from openstreetmap@… to geocoding@…

comment:2 Changed 2 years ago by lonvia

  • Status changed from new to closed
  • Resolution set to fixed

Works now.

Note: See TracTickets for help on using tickets.