Opened 9 years ago

Closed 9 years ago

#3048 closed defect (fixed)

Zooming impossible: Wrong Projection by default?

Reported by: ymapper Owned by: cbro@…
Priority: major Milestone:
Component: merkaartor Version:
Keywords: Cc:

Description

With 0.16 on Vista (and with 0.17 svn-debug) I now get the problem that whenever I load GPX files, Merkaator cannot zoom into the bbox for the GPX anymore and the viewport is either 0,0,0,0 or NaN. I think this is the same problem reported as in http://article.gmane.org/gmane.comp.gis.openstreetmap.merkaartor/2046/match=nan

I think I tracked this down: the reason is that on the projections it goes to automatically to OSGB36, which might either not be supported by the proj library or is not applicable to the region I am using. Setting this to EPSG:4326 in View->Set Projection solves the problem, but it left me stumped for a while.

Solution: by default set this to EPSG:4326.

Change History (3)

comment:1 Changed 9 years ago by Chris Browet

That might be a leftover in your configuration, because I cannot reproduce.

Could you try to reproduce (with latest 0.17-debug) when launching merkaartor with "-p", please.

"-p" will run merkaartor in portable mode, thus creating a new and clean config (in "merkaartor.ini" in the app dir). Not running merk with "-p" will revert to your original configuration, so no risk of loosing it.

comment:2 Changed 9 years ago by Chris Browet

Nevermind. I can reproduce it. Looks like it is windows specific or locale specific.

comment:3 Changed 9 years ago by Chris Browet

Resolution: fixed
Status: newclosed

Fixed

Note: See TracTickets for help on using tickets.