Opened 9 years ago

Closed 9 years ago

#3115 closed defect (wontfix)

"View relation on larger map" zoom behaviour unsettling

Reported by: stevage Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: zoom, relation, link Cc:

Description

1) View a relation page (eg http://www.openstreetmap.org/browse/relation/385628) 2) Click "View relation on larger map" 3) Goes to http://www.openstreetmap.org/?relation=385628 4) Initial view shows the whole world zoomed way out 5) Then apparently it works out the size of the relation, and zooms to an appropriate level. (Takes approx 8 seconds for me)

I actually came here to report that it was a bug and didn't work at all. Only on trying to reproduce did I realise that it eventually zooms in and shows the relation correctly. Hopefully there's a way of making this behave a lot more nicely, by guessing an approximate zoom level first or something. (Not sure if this is mapnik or something else. Guessing mapnik.)

Change History (2)

comment:1 Changed 9 years ago by Ldp

Component: mapnikwebsite
Owner: changed from mapnik-team@… to Tom Hughes

Not mapnik.

It's not really a bug either. Fetching a relation from the API can take some time, and the extent of the relation is not known to the website until the API delivers that relation.

As a relation can be anywhere in the world, there's no other thing to do than to show the entire world at first.

comment:2 Changed 9 years ago by Tom Hughes

Resolution: wontfix
Status: newclosed

As Ldp says, the problem is that we don't know the bounding box for the relation until the API has returned the data and that is what causes the delay - there isn't a lot we can easily do about that.

Note: See TracTickets for help on using tickets.