Opened 9 years ago

Closed 9 years ago

#3116 closed defect (fixed)

TemplateSyntaxError when viewing own question on help.osm.org

Reported by: Tordanik Owned by: Tom Hughes
Priority: major Milestone:
Component: website Version:
Keywords: Cc: richlv

Description

I've posted the question "Adding a blog to blogs.openstreetmap.org" to help.osm.org:

http://help.openstreetmap.org/questions/58/adding-a-blog-to-blogsopenstreetmaporg

After successfully creating the question, I received an error page. The same error appears whenever I want to view my own question. Deleting the cookie will allow me to view the question, but only until I log in again.

The error page is attached to this ticket.

Attachments (1)

error page.zip (23.8 KB) - added by Tordanik 9 years ago.
Error page that appears when I try to view the question (HTML, zipped)

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Tordanik

Attachment: error page.zip added

Error page that appears when I try to view the question (HTML, zipped)

comment:1 Changed 9 years ago by richlv

i'm seeing the same error. this issue was hard to find, because i searched for keyword from the first line of the error output :)

Caught an exception while rendering: 'NoneType?' object is not callable

comment:2 Changed 9 years ago by richlv

Cc: richlv added

comment:3 Changed 9 years ago by NE2

http://help.openstreetmap.org/questions/153/how-do-you-tell-if-a-minor-service-road-is-accessprivate-destination-or-permissive gave me an error until I deleted the help.osm.org sessionid cookie. Of course I can't reply with the cookie deleted.

comment:4 Changed 9 years ago by Tom Hughes

Resolution: fixed
Status: newclosed

I think this should be fixed now. The OSQA report is here:

http://meta.osqa.net/questions/3792/error-when-posting-a-question

and the fix which I have just deployed:

http://svn.osqa.net/changelog/OSQA/osqa/trunk?cs=524

Note: See TracTickets for help on using tickets.