Opened 9 years ago

Closed 9 years ago

#3136 closed enhancement (duplicate)

prevent multiple repeated nodes at the end of way

Reported by: amm Owned by: richard@…
Priority: minor Milestone: Wishlist
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

It should probably not be possible to create duplicate or even higher repeats of nodes at the end of the way, or at least warn the user.

An example of the issue is way http://www.openstreetmap.org/browse/way/25666064/history (version 3)

The last node ( http://www.openstreetmap.org/browse/node/269640446 ) appears three times repeated. As it is not my way, I can only speculate what happend, but I would guess, the user tried to end the way and repeatedly clicked on the not, not quite fast enough for a double click.

Given the account was only created about two hours befor the edit, it is clearly a newbe mistake , but one the editor can hopefully help prevent, hence me reporting it here (i.e it is easier to blame the editor than the user... ;-)).

That way has more issues too (that node is infact 5 times in the way) but that is a different matter.

Change History (1)

comment:1 Changed 9 years ago by Richard

Resolution: duplicate
Status: newclosed

Duplicate of #2501. Steps to reproduce please.

Note: See TracTickets for help on using tickets.