Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3210 closed defect (invalid)

osmosis doesn't work at all

Reported by: Malmis Owned by: Malmis
Priority: major Milestone:
Component: osmosis Version:
Keywords: Cc:

Description

http://pastie.org/1139837

i get the same error with every version i use, even svn build.
using ubuntu maverick (10.10), also debian.

Change History (6)

comment:1 Changed 8 years ago by TomH

  • Component changed from admin to osmosis
  • Owner changed from tom@… to brett@…

comment:2 Changed 8 years ago by Malmis

actually version 0.35.1 works for me, but not 0.36 or svn.

comment:3 Changed 8 years ago by brett@…

  • Owner changed from brett@… to Malmis
  • Status changed from new to assigned

Can you please ask this question on the mailing list? Given the lack of other reports of this error it doesn't seem like a defect in Osmosis.

Where have you obtained the 0.36 build from? The pastebin message is not from a binary distribution because there is no "package" directory in a binary distribution.

When running from SVN, what command did you use to compile the application?

comment:4 Changed 8 years ago by Malmis

i used "ant" to build. but it fails to fully complete because i don't have db setup.
http://bretth.dev.openstreetmap.org/osmosis-build/osmosis-0.36.tgz was the file i used for 0.36, it includes osmosis-package-0.36 and osmosis-0.36

comment:5 Changed 8 years ago by Malmis

  • Resolution set to invalid
  • Status changed from assigned to closed

seems like i used wrong package then... works men using osmosis-0.37-SNAPSHOT dir, but not osmosis-package-0.37-SNAPSHOT.

comment:6 Changed 8 years ago by brett@…

There was a bug in the package script which meant the launch scripts were being included twice. Once in the osmosis-0.37-SNAPSHOT directory, and once in the osmosis-package-0.37-SNAPSHOT directory.
I have fixed it so that they are only being included in the osmosis-0.37-SNAPSHOT directory, and fixed those scripts so that they are marked as executable.

It's fixed in the latest Hudson build:
http://dev.openstreetmap.de:23457/hudson/job/osmosis-SNAPSHOT-ant/lastSuccessfulBuild/artifact/trunk/package/distrib/

Note: See TracTickets for help on using tickets.