Opened 9 years ago

Closed 5 years ago

#3215 closed defect (wontfix)

[roads] ref tags are not rendered when highway=secondary + bridge=yes are used

Reported by: rickmastfan67 Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc: rickmastfan67, lpechacek

Description

When ref tags are present on highway=secondary + bridge=yes ways, the ref tags are not being rendered. Even on the lowest zooms it will not render period.

Here's an example on a long bridge where it's very noticeable on z=18 because if you go on either side of the bridge, you can see the ref tags on the normal roads that don't have the bridge=yes tags: http://www.openstreetmap.org/?way=29425774

Change History (9)

comment:1 Changed 9 years ago by Ldp

This is intended behaviour, see #2136.

comment:2 Changed 9 years ago by rickmastfan67

So, you're saying that the REF tags don't get rendered on bridges that are Secondary and lower classification?? Yet they are on Primary and up? Kinda stupid if you ask me. I would think that Secondary should be the lowest (at least) to get the ref tags on bridges as well.

As another example, here's Florida State Highway 656 crossing the Intercoastal Waterway on a very long bridge. http://www.openstreetmap.org/?lat=27.632457&lon=-80.370747&zoom=18&layers=M You would think at least ONE ref tag would be rendered on it at z=18 or z=17, no?

If you don't want to put them on territory highways, fine. But Secondary Highways should get them. Especially if they have a very long bridge on them.

comment:3 Changed 9 years ago by Ldp

It was done so the ref shield would not hide small bridges, and we don't test for the length of a bridge. Yet. Keeping this open to think about that.

comment:4 in reply to:  3 Changed 9 years ago by rickmastfan67

Cc: rickmastfan67 added

Replying to Ldp:

It was done so the ref shield would not hide small bridges, and we don't test for the length of a bridge. Yet. Keeping this open to think about that.

Well, the ref tags on motorways and trunk highways with small bridges still often have the ref tag hide the bridge. Just saying. ;) http://www.openstreetmap.org/?lat=30.35584&lon=-81.66117&zoom=17&layers=M

But I personally wouldn't hastily go and attempt to remove them on Primary, Trunk, & Motorway's because I've seen really long bridges on some of those types of highways that really NEED the ref tag (like Interstates).

comment:5 Changed 9 years ago by Ldp

The original request was for secondary bridges, and higher classed roads weren't done at that time, partly because of the reasons you mentioned.

comment:6 in reply to:  3 Changed 8 years ago by lpechacek

Replying to Ldp:

It was done so the ref shield would not hide small bridges, and we don't test for the length of a bridge.

I've spotted bridges that were missing the "ref" tags just because of tagging for the renderer. Short bridges were hidden behind the ref shield, so the users decided to remove the tag.

How much work is it to implement the shield rendering based on the bridge length? Does it mean tweaking osm.xml only or does it involve hacking Mapnik itsef?

comment:7 Changed 8 years ago by lpechacek

Cc: lpechacek added

comment:8 Changed 5 years ago by math1985

Summary: ref tags are not rendered when highway=secondary + bridge=yes are used[roads] ref tags are not rendered when highway=secondary + bridge=yes are used

comment:9 Changed 5 years ago by math1985

Resolution: wontfix
Status: newclosed

We don't store bridge length in the database, so we have currently no way to implement this. I will therefore close this issue as wontfix.

Note: See TracTickets for help on using tickets.