Opened 9 years ago

Closed 9 years ago

#3251 closed enhancement (fixed)

draggable permalinks

Reported by: steelman Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: permalink Cc:

Description

Make the map permaliks draggable to outsied applications, the same way as the "Link" in the Google Maps is. Today when I try to drag any of them I drag the map instead.

Attachments (2)

index.html.erb (7.9 KB) - added by steelman 9 years ago.
Place permalinks outside of the map div to make them draggable
index.html.erb.diff (653 bytes) - added by steelman 9 years ago.
Place permalinks outside of the map div to make them draggable (this is the diff)

Download all attachments as: .zip

Change History (7)

comment:1 Changed 9 years ago by Tom Hughes

Resolution: wontfix
Status: newclosed

This is an OpenLayers? issue and not something we have any control over as far as I know - the problem is that OpenLayers? intercepts all the mouse events over the map area so the normal browser handling of drags on links is suppressed.

The OpenLayers? bug tracker is at http://trac.openlayers.org/ if you want to report this as a problem with OpenLayers?.

comment:2 Changed 9 years ago by steelman

Resolution: wontfix
Status: closedreopened

It is the OpenLayers? issue only if the permalink div is a child of the map div. If, however, you make them siblings inside the content div, then the dragging work as I suggested. No JS code and no CSS need to be changed!

comment:3 Changed 9 years ago by Tom Hughes

Well if you know how to fix it then I look forward to receiving your patch.

Changed 9 years ago by steelman

Attachment: index.html.erb added

Place permalinks outside of the map div to make them draggable

Changed 9 years ago by steelman

Attachment: index.html.erb.diff added

Place permalinks outside of the map div to make them draggable (this is the diff)

comment:4 Changed 9 years ago by steelman

Ping!

comment:5 Changed 9 years ago by Tom Hughes

Resolution: fixed
Status: reopenedclosed

Applied.

Note: See TracTickets for help on using tickets.