Opened 8 years ago

Last modified 5 years ago

#3254 reopened defect

Turn restriction broken by potlatch

Reported by: Nakor Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version: 2.0
Keywords: Cc:

Description

See changeset http://www.openstreetmap.org/browse/changeset/5676110 where way http://www.openstreetmap.org/browse/way/54223082 was broken in three pieces.

Way http://www.openstreetmap.org/browse/way/54223082 belongs to turn restriction http://www.openstreetmap.org/browse/relation/542976 which in its version 2 has three members with to role as a result of this edit.

Only the resulting way connected to the via node should have been kept in the relation.

Change History (5)

comment:1 Changed 8 years ago by Nakor

  • Component changed from admin to potlatch (flash editor)
  • Owner changed from tom@… to richard@…

comment:2 Changed 7 years ago by hlaw

Noting that halcyon/connection/actions/SplitWayAction.as has been changed to fix this commit diff, but splitting ways under "to" or "from" roles of turn restrictions still does not work correctly -- in cases when the original way (rather then the new way) should no longer be involved a turn restriction, it is not removed from the relation. I have fixed a number of turn restrictions broken as a result in this changeset - see the history on the relations fixed for examples.

I suspect lines 80-87 under SplitWayAction.as still do not work as intended but I am not familiar with the source to see exactly why.

comment:3 Changed 5 years ago by iandees

  • Resolution set to wontfix
  • Status changed from new to closed

Cleaning aging tickets.

comment:4 Changed 5 years ago by hlaw

  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Version changed from 1.0 to 2.0

The issue is still here, and as there seems no plan to deprecate Potlatch (and users are still using it) they would continue to break turn restrictions unintentionally without fixing this. Unlike new features on relations, I suppose not much effort is needed to fix this for someone familiar with the code, as there are already logics to deal with this as I read it, but they are just not working as intended.

comment:5 Changed 5 years ago by rickmastfan67

This should go for all relations.

I just found that a user unknowingly that destroyed several route relations for Pennsylvania State Highways via P2.

Note: See TracTickets for help on using tickets.