Opened 9 years ago

Closed 5 years ago

#3303 closed defect (fixed)

Mapnik renders "ghost" labels (underground_cable)

Reported by: elektranox@… Owned by: mapnik-team@…
Priority: minor Milestone: Wishlist
Component: mapnik Version:
Keywords: Cc:

Description

Hi,

Currently the mapnik renders the name of an underground cable, but not the cable. This creates more harm than good, as you can see on the first link (there's an "069" renderd next to "Willerstraße"). When you don't know of the cable (see second link) you will wonder what this is about.

Please make mapnik either render the cable or stop rendering the cable's name.

-- Sebastian

Change History (3)

comment:1 Changed 8 years ago by stanton

Summary: Mapnik renders underground_cable's name, but not the cableMapnik renders "ghost" labels

Underground cables are not the only object that's affected. I have notices the same with ski runs having only piste:* tags and name=*. It seems that Mapnik renders name labels along a lot of (all?) ways even if it doesn't render the ways themselves.

The fix should be simple: render labels ONLY for ways which get rendered, else suppress the labels.

comment:2 Changed 5 years ago by math1985

Summary: Mapnik renders "ghost" labelsMapnik renders "ghost" labels (underground_cable)

comment:3 Changed 5 years ago by pnorman

Resolution: fixed
Status: newclosed

The place to report issues with openstreetmap-carto, the "standard" style on openstreetmap.org is on its issue tracker. The old Mapnik XML based stylesheets have been retired.

The catch-alls that were the cause of many of these names have been removed.

Note: See TracTickets for help on using tickets.