Opened 9 years ago

Closed 6 years ago

#3326 closed defect (wontfix)

Error on saving - way changed since last download - but way is new

Reported by: Mark Pulley Owned by: richard@…
Priority: major Milestone:
Component: potlatch (flash editor) Version:
Keywords: Cc:

Description

I have noticed this intermittently but this happened twice last night.

First time (http://www.openstreetmap.org/browse/changeset/6288168 ) I did a large number of edits prior to saving. One way http://www.openstreetmap.org/browse/way/38345041 was split into several sections to add a ford and make the end loop one way. On saving, one section refused to save - error message stated that it had been changed on the server subsequent to my change - however the way had a negative number, and no-one else had made any changes. (When I clicked the button to keep my version, and clicked OK for potlatch to show me the way in question, the view in potlatch moved to near here http://www.openstreetmap.org/?lat=-30.1664&lon=129.2392&zoom=14 - almost the other side of the continent, so impossible to go back to the original location.) I ended up selecting the option to keep the way on the server - this left the nodes intact, but the way didn't save.

I tried again with a new changeset ( http://www.openstreetmap.org/browse/changeset/6288303 ) - this time I added the way, moving a couple of nodes to place a cattle grid - then saved immediately. The same error came up, stating the way (with a negative number) was previously changed on the server. I selected the option to use the version on the server - this again moved my view position, but this time only within a few hundred metres. This deleted the way again. I ended up adding the way over the nodes, then saving, then moving the nodes and adding the cattle grid, then saving again.

Change History (2)

comment:1 Changed 9 years ago by Richard

Known problem but sadly no steps to reproduce as yet. If you can provide consistent steps to reproduce that'd be greatly appreciated.

comment:2 Changed 6 years ago by iandees

Resolution: wontfix
Status: newclosed

Cleaning aging tickets.

Note: See TracTickets for help on using tickets.