Opened 9 years ago

Closed 5 years ago

#3332 closed defect (fixed)

Abandoned railways should not be rendered by default

Reported by: spontex Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

Abandoned railways should not be rendered on the default OSM map using Mapnik. It should only be an option for some historical railway maps.

See the following links for discussion: http://chris-osm.blogspot.com/2009/07/abandoned-railways.html [http://help.openstreetmap.org/questions/361/why-render-abandoned-

railways]

http://www.mail-archive.com/talk@openstreetmap.org/msg11895.html

Change History (5)

comment:1 Changed 9 years ago by spontex

On this map, an abandoned railway crosses an existing airport, which lessens readability: http://osm.org/go/xVH_1BzX

comment:2 Changed 9 years ago by Tom Hughes

Component: adminmapnik
Owner: changed from Tom Hughes to mapnik-team@…

comment:3 Changed 5 years ago by pnorman

Resolution: fixed
Status: newclosed

The place to report issues with openstreetmap-carto, the "standard" style on openstreetmap.org is on its issue tracker. The old Mapnik XML based stylesheets have been retired.

The catch-alls that were the cause of many of these names have been removed. It also seems unlikely that this particular instance was mapped correctly - I'd normally expect the abandoned railway to be obliterated by an airport.

comment:4 Changed 5 years ago by math1985

Resolution: fixed
Status: closedreopened

This is not caused by a catch-all. We indeed do explicitly render abandoned railways, and I agree we shouldn't render them. I will re-open this.

comment:5 Changed 5 years ago by math1985

Resolution: fixed
Status: reopenedclosed

Abandoned railways are now no longer rendered.

Note: See TracTickets for help on using tickets.