Opened 9 years ago

Closed 6 years ago

#3333 closed defect (duplicate)

Kingdom Halls rendered with crosses

Reported by: donaciano2000@… Owned by: mapnik-team
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

Jehovah's Witnesses do not use the cross so the rendering of Kingdom Halls with the same icon as other churches with religion=christian would be offensive and incorrect.

There should be an exception for the amenity=place_of_worship with religion=christian icon when denomination=jehovahs_witness

The key name="Kingdom Hall" should not be used to identify since it varies with language.

Since Jehovah's Witnesses do not recognize any official symbol or icon a simple generic square or a building without a cross would be fine.

Having a place for exceptions based on denomination is a good addition since it could render alternate icons for religious denominations that distinguish themselves from others in their general religion type.

Change History (4)

comment:1 Changed 8 years ago by Ldp

Duplicate of #3123.

comment:2 Changed 8 years ago by Ldp

This will have to stay on hold until we get denomination=* in the rendering db.

comment:4 Changed 6 years ago by CloCkWeRX

Resolution: duplicate
Status: newclosed

Closing, as that updated pull request exists

Note: See TracTickets for help on using tickets.