Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#3360 closed defect (fixed)

Switching backgrounds doesn't respect Dim setting

Reported by: EdLoach Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version: 2.0
Keywords: Cc:

Description

I noticed this when I switched from Bing imagery to OS Streetview and back to Bing imagery. Bing was dim, so I went to clear the checkbox to find it was already clear (remembered from previous session, and respected when the editor starts). I've not tried the Sharpen setting, but guess it might be similar.

Change History (4)

comment:1 Changed 8 years ago by stevage

Resolution: worksforme
Status: newclosed

If I'm reading this right:

  1. On Bing, set dim
  2. Change to something else
  3. ?
  4. Change back to Bing
  5. Bing shows dim, but dim is unchecked.

I can't reproduce this. I vaguely recall seeing the checkbox set to the wrong state at some point, but the above bug report doesn't describe that.

comment:2 Changed 8 years ago by stevage

Resolution: worksforme
Status: closedreopened

Oh, ok, it's this:

  1. Set background to dim
  2. Restart app
  3. Background is dimmed, but checkbox is unset.

It doesn't always happen - I can't reproduce 100%. But the really weird thing is, when stepping through, the relevant variables are completely consistent with the background *not* being dimmed. initParams.dim_background is false, TileSet?.init gets called with dim=false, alpha gets set to 1, and when alpha gets queried to set the checkbox state, it's 1, so the checkbox *should* be unset.

So two questions: why is initParams.dim_background false, and why on earth does the background display dimmed when tileset.alpha=1? But as I can't reliably reproduce, it's hard to investigate.

comment:3 Changed 8 years ago by stevage

Resolution: fixed
Status: reopenedclosed

Fixed. Ow. My poor confused brain. [25522]. I don't even know if this was the OP's problem, but there was a bug where Yahoo imagery was always dimmed.

comment:4 Changed 8 years ago by stevage

Ed Loach's follow up comment:


Go to edit mode. It has correctly remembered that when last editing I used Bing undimmed. Switch to Mapnik background layer. This shows as dimmed though the dim check box still suggests it should be undimmed. Check the box and uncheck it to get Mapnik not dim. Switch back to Bing layer. Again check box remains as not checked, but background defaults to dimmed. To get it not dim you have to check and clear the checkbox.


I have definitely now fixed this in [25525]. Wow, it really does behave a lot more properly now. (Aside: who even uses the dim setting? I'm more likely to want the background at full brightness and the overlaid map dimmed...)

Note: See TracTickets for help on using tickets.