Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#3362 closed enhancement (wontfix)

Warning against misaligned Bing aerials

Reported by: Oli-Wan Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version:
Keywords: Cc: DJTerentjev@…

Description

Potlatch 2 confronts the (newbie) user with Bing Maps, without any warning whatsoever that the maps may be shifted in position or distorted. We have seen the first instances (and will continue to see many more) of people taking Bing Maps at face value, "correcting" existing objects to wrong positions or drawing new objects where Bing falsely suggests them to be.

I firmly believe that there should be a warning when/before Bing Maps are displayed in the background, either as a confirmation dialog or at some sufficiently prominent position on the editor's interface.

It might even be wise to not display Bing as the default background, but you've probably discussed that many times before... so all I ask for is a clear warning to the user.

It's not an actual "bug" in Potlatch 2 (sorry to bother you guys, after you've done such a great job with this editor), but it will create many unnecessary errors in OSM.

Change History (5)

comment:1 Changed 8 years ago by stevage

Probably the best way to tackle this is by implementing the "True Offset": http://wiki.openstreetmap.org/wiki/True_Offset_Process

comment:2 Changed 8 years ago by Oli-Wan

Maybe not the best, but certainly the simplest way is still to warn the user. I don't want to keep on writing emails to mappers unaware of Bing's deficiencies forever.

comment:3 Changed 7 years ago by DJTerentjev@…

Cc: DJTerentjev@… added

Warning can be just simple dialogue with information about chance imagery offset. For next time user should have possibility to hide this dialogue. Please see the image:

http://josm.openstreetmap.de/attachment/ticket/7450/JOSM%20Eng.png

Thanks

comment:4 Changed 7 years ago by Oli-Wan

Resolution: wontfix
Status: newclosed
Summary: Warning against misaligned Bing MapsWarning against misaligned Bing aerials

Closing this, as there is obviously no hope that such a warning will ever be included.

comment:5 Changed 7 years ago by Richard

The problem is that, if we were to implement every warning everyone requests about anything a newbie could possibly do wrong, the list of warnings would be so long that

  • it would fill two pages
  • no-one would ever read it.

There are really two solutions: one is for someone to implement (as Steve B says) True Offset Process or similar, such that offset is no longer a problem; or for someone to write better docs than the woeful existing ones (and that includes P2's help docs, which I'll happily admit are not stellar). We can't expect everything to be handled by modal warning dialogues.

Note: See TracTickets for help on using tickets.