Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3365 closed enhancement (fixed)

trac configuration: show diff view for changeset

Reported by: sebastiank Owned by: Tom Hughes
Priority: minor Milestone:
Component: admin Version:
Keywords: Cc:

Description

When displaying a changeset, trac can show a unified diff, like this:

http://trac.openstreetmap.org/changeset/24552

however this does not work, when more than 1 file has been touched

http://trac.openstreetmap.org/changeset/24567

It would be handy, if it showed the diff for each changeset

max_diff_bytes and max_diff_files might be relevant settings.

Change History (4)

comment:1 Changed 9 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

As best I can tell this is a bug in trac and therefore outside our control. The only limits we have configured are 100 files or 100000 bytes. Those are in place to prevent problems caused by large changesets taking a long time to render.

comment:2 Changed 9 years ago by Tom Hughes

Resolution: invalid
Status: closedreopened

comment:3 Changed 9 years ago by Tom Hughes

Resolution: fixed
Status: reopenedclosed

Apparently max_diff_bytes doesn't work the way any sane person would expect - it doesn't limit the size of the diff but rather the size of the files being diffed.

The total size of the files in that commit was more than 100Kb hence the diff wasn't shown.

I've removed that limit for now since we have a robots file blocking spiders from browsing the changsesets now anyway.

comment:4 Changed 9 years ago by sebastiank

thanks

Note: See TracTickets for help on using tickets.