Ticket #3385 (closed defect: fixed)

Opened 3 years ago

Last modified 6 months ago

Undo/redo bugs on DrawWay

Reported by: Richard Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

A couple of ways to foul it up entertainingly:

  • Start drawing a way. Click 'Undo' while the elastic is available. Enjoy all the fun of drawing a way without any of the consequences!
  • Start drawing a way. Press Delete or Escape to end it (which maps to Undo). Click Redo. A dupe node appears (which it shouldn't). Now click the dupe node and press delete. Select a way somewhere and shift-click to add a new node. The result is a Flash exception in hitTest (WayUI line 545) which is the usual tell-tale sign of a mismatch between Ways and WayUIs.

Change History

comment:1 Changed 3 years ago by stevage

I had a bit of a look. It's not entirely obvious what the correct behaviour is when pressing "undo" in the middle of a draw sequence. A few possibilities: 1) Undo should be like delete/minus, except creating "redo" actions rather than "undo" ones. 2) Undo should be exactly like delete/minus (ok, that would be weird) 3) Undo should instantly remove the whole drawn way. 4) Nothing - disable. (Not as bizarre as it sounds, various other editing programs work this way.)

There's also two choices about how the whole undo/redo thing works for drawn nodes: 1) Individual nodes can be undone/redone 2) The whole sequence (between starting drawing and pressing enter/finishing) is one undo step.

comment:2 Changed 2 years ago by stevage

Not sure if I fixed the first one in my fix for #3860, but in any case, I can't reproduce it now. (Yay). The second gives me a different error, slightly earlier in the sequence.

comment:3 Changed 6 months ago by compdude

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.