Opened 9 years ago

Closed 9 years ago

#3388 closed defect (fixed)

Strange behaviour when editing tag part of existing tag

Reported by: StellanL Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version: 2.0
Keywords: Cc:

Description

If I edit the tag part, and that edit causes the tag to sort differently in the list, the change is applied immediately on hitting TAB, causing the value part of the edit to be in the wrong place.

Change History (4)

comment:1 Changed 9 years ago by SK53

I think I've come across this in editing existing tags in the Advanced pane.

Position the cursor within the string to be changed, insert (or overtype) a character and the cursor jumps to the end of the string.

If multiple characters are added the second and subsequent characters are appended to the end of the string.

comment:2 Changed 9 years ago by StellanL

No, I think that is a different bug - to me that only happens in the VALUE part. That is perhaps related to why it is impossible to write "riverbank" since it begins with "river"...

comment:3 Changed 9 years ago by Heiko "Mueck" Jacobs

Before wrting "my" ticket http://trac.openstreetmap.org/ticket/3403 I didn't saw, that this error is already here ... My description has an example of tags, where this error occur.

The error in the comment is indeed another error. I also had this (different) problem.

comment:4 Changed 9 years ago by Richard

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.