Ticket #3444 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Potlatch 2: Have to click twice to take an action

Reported by: techlady Owned by: potlatch-dev@…
Priority: major Milestone: OSM 1.0
Component: potlatch2 Version: 2.0
Keywords: tabs delete ways Cc:

Description

There are several instances in Potlatch 2 where clicking once on something, such as the tab for "Physical" does not work. Here are three examples that I encounter frequently. --I have created a way and wish to tag it as "bridge." I click on "Physical" to open that tab. Nothing happens. So I click on the tab next to it, "Cycling," then click on "Physical" again. Now it opens. This takes time and energy, and needs to be fixed. --The same thing happens with the "Permission" tab. --A similar thing happens when I highlight a part of a way to delete it. I define the way, and it is highlighted. But, when I click to delete it, nothing happens. So I have to highlight something else on the screen, then click again on the segment that I want to delete. Now, I can delete it. This is annoying and also wastes time. These little mistakes can make it difficult to edit. Each time I had to find my own workaround. New users simply may give up or conclude that our software doesn't work. At that point, we've lost them.

Change History

comment:1 Changed 3 years ago by Richard

As with the previous ticket, this is a known long-term issue that is probably due to a bug in a third-party component (Flex in the previous case, the FlexLib? SuperTabNavigator? in this one) and once we can identify what the bug actually is (in someone else's code) we'll be able to fix it. See also #3368 which is considering replacing the SuperTabNavigator? entirely.

comment:2 Changed 3 years ago by StellanL

I can reproduce the non-responsive tabs bug. If I select a tab other than Basic, and leave that tab selected when I deselect the way, then when I select a way again all tabs work immediately, except the one that was selected for the last way, which only works after something else is selected. Apparently the tab control remembers which is the "selected" tab separately from which is the "visible" tab, and only the visible is reset when a new way us selected.

comment:3 Changed 3 years ago by Richard

Yep, we can all reproduce it, we just need someone to fix FlexLib?. ;)

comment:4 Changed 3 years ago by Richard

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in v2.2.

Note: See TracTickets for help on using tickets.