Opened 9 years ago

Closed 6 years ago

#3453 closed defect (worksforme)

Wiki eats changes (doesn't detect conflicts?)

Reported by: AMDmi3 Owned by: Grant Slater
Priority: major Milestone:
Component: wiki Version:
Keywords: Cc:

Description

In last two days I've encountered at least three times of unintended change reverts on wiki. Seems like it doesn't detect conflicts and just lets user edit and save old version of a page while other users add changes as well, which leads to loss of latter changes. Examples:

http://wiki.openstreetmap.org/w/index.php?title=Talk%3AProposed_features%2FBuilding_attributes&action=historysubmit&diff=584286&oldid=584270

http://wiki.openstreetmap.org/w/index.php?title=Proposed_features%2Fdefault_layer_for_bridge_and_tunnel&action=historysubmit&diff=584860&oldid=584848

Change History (3)

comment:1 Changed 9 years ago by Tom Hughes

Please, be serious, of course the wiki detects conflicts - it's just mediawiki the same as wikipedia.

Do you have any actually evidence that "User 5359" didn't deliberately remove those two lines?

comment:2 Changed 9 years ago by AMDmi3

I meant that probably conflict detection is broken, as these rewrites are just happening. In second case the change was confirmed to be unintended, and the user has no idea why such a thing has happened. In the first case, I didn't ask, but I really doubt anyone would intentionally revert a typo fix and other recent changes along with adding a comment.

comment:3 Changed 6 years ago by Grant Slater

Resolution: worksforme
Status: newclosed

closing. If still an issue, re-open.

Note: See TracTickets for help on using tickets.