Opened 8 years ago

Closed 8 years ago

#3477 closed defect (worksforme)

Click+drag navigation not working in Potlatch 2

Reported by: Andy Clegg Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

Click+drag does not seem to move the viewport.

  • I can click+drag objects (ways, nodes, draggable windows etc.)
  • Space+click+drag for aligning background works
  • Trying to navigate via click+drag briefly displays the 'Loading data...' box so it is trying to do something
  • Zooming in and out works
  • Everything else appears to work perfectly

Using Flash Player 10.2-beta 'Square' for 64-bit Linux, latest version (Preview 3). Browser is Firefox 3.6.13; Operating System is Fedora 13. Using the default openstreetmap.org installation of Potlatch 2.

Change History (5)

comment:1 Changed 8 years ago by Richard

This appears to be a bug with the Flash Player Linux beta - it's the common factor in similar reports we've received. I strongly suspect that it doesn't implement DisplayObject?.scrollRect correctly. (I'm not on Linux so can't reproduce it but perhaps one of our other developers can!)

comment:2 Changed 8 years ago by Andy Clegg

Thanks for the info - I've reverted to the latest release version of Flash (10.1.102.65), 32 bit version, and click+drag now works.

comment:3 Changed 8 years ago by Richard

Filed with Adobe JIRA at https://bugs.adobe.com/jira/browse/FP-6088 . If you can add any more to the report, please do.

comment:4 Changed 8 years ago by Richard

Adobe have closed the bug (https://bugs.adobe.com/jira/browse/FP-6088) due to not being able to reproduce. If you can reproduce it, please do follow up there with details.

comment:5 Changed 8 years ago by Andy Clegg

Resolution: worksforme
Status: newclosed

This seems to have resolved itself - not sure if PL2 has been updated? Anyway, closing as the problem is no longer reproducible by me :-)

Note: See TracTickets for help on using tickets.