Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3479 closed defect (fixed)

GPX upload fails, server returns 500

Reported by: saimhe Owned by: tom@…
Priority: major Milestone:
Component: api Version:
Keywords: gpx upload 500 Cc:

Description

IIRC it started yesterday. Might be a temporary administrative problem but why does it return a few times in a year? I'm considering that as "defect".

If uploading a GPX through JOSM with DirectUpload? plugin, there's an error message about denied permissions on the server side. I'm attaching a protocol transcript captured by Wireshark.

If uploading a GPX through http://www.openstreetmap.org/trace/create, the new entry marked "PENDING" etc does not appear. There is only the green text "Your GPX file has been uploaded ..." which is misleading. No new entry even after considerable waiting. No reports in my mailbox.

A few other users are also affected: http://www.openstreetmap.org/user/RGPS/diary/12880

Attachments (1)

apifail.txt (1.5 KB) - added by saimhe 8 years ago.
HTTP request+response from Wireshark, privacy edited

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by saimhe

HTTP request+response from Wireshark, privacy edited

comment:1 Changed 8 years ago by TomH

  • Resolution set to fixed
  • Status changed from new to closed

Actually it started on Saturday afternoon, but only on one server so it was sometimes working.

Thanks for the detailed report anyway - the problem should be fixed now.

I'm not sure what you mean about it happening several times a year though - to my knowledge this is the first time a problem like this has occurred in the three and a half years that I've been looking after things.

comment:2 Changed 8 years ago by saimhe

Thanks for the fix.

Ok, let's clean up exaggerations. Before it happened for me in first half of 2010 (back then I spent lots of time tidying and uploading old traces), and my first thought then was "not again!". The first time, well... might be even in 2009. Don't remember for how long it was, most likely the problem went away next day.

Note: See TracTickets for help on using tickets.