Opened 8 years ago

Closed 5 years ago

#3488 closed enhancement (fixed)

Improve search if housenumber/postal code is not found

Reported by: ToB Owned by: twain
Priority: minor Milestone:
Component: nominatim Version:
Keywords: Cc: ESYSCODER

Description

Finding the following street does not work in Nominatim:

43 blv. du 11 novembre 1918 69622 Villeurbanne

There are a couple of issues:

  • The postal code seems to be one for a mailbox (CEDEX) and is not listed in OpenOffice?
  • The house number is not listed either
  • "blv." is not searched for as "Boulevard"

Expected: If not found, postal code and house numbers should be ignored and "blv." should be also searched for by "Boulevard"

Doing all the changes, Nominatim finds it:

boulevard du 11 novembre 1918, Villeurbanne

Change History (6)

comment:1 Changed 8 years ago by twain

Owner: changed from openstreetmap@… to twain
Priority: majorminor
Status: newassigned
Type: defectenhancement

The problem is purely the 1918. If I remove it from the query then everything else works.

e.g.:

http://open.mapquestapi.com/nominatim/v1/search.php?q=43+blv+du+11+novembre%2C+Villeurbanne&viewbox=-189.85%2C82.25%2C189.85%2C-74.26

I have no idea what the 1918 refers to and I can't see any relevant data in OSM.

comment:2 Changed 8 years ago by ToB

Hmm, might be also just a data bug. In OSM the street misses the "1918". Still, searching for "43 blv. du 11 novembre, 69622 Villeurbanne" did not help either - only "blv. du 11 novembre, Villeurbanne" worked.

Thus, the "blv." -> "boulevard" worked, ignoring the house number worked, but ignoring the postal code if nothing could be found, does not seem to work.

  • * *

"I have no idea what the 1918 refers to and I can't see any relevant data in OSM."

Seemingly the year (11th November 1918).

comment:3 Changed 7 years ago by datendelphin

The problem is, that the number pair 1918 69622 is recognized as a lat,lon pair.

comment:4 Changed 7 years ago by Sarah Hoffmann

Solved the problem with badly recognized lat/lon pair. (Will be deployed shortly.)

There is still the issue, though, that the unknown postcode is not ignored.

comment:5 Changed 7 years ago by ESYSCODER

Cc: ESYSCODER added

comment:6 Changed 5 years ago by Sarah Hoffmann

Resolution: fixed
Status: assignedclosed

The lat/lon issue has been resolved for a while. For ignoring postcodes, see #2497.

Note: See TracTickets for help on using tickets.