Opened 8 years ago

Closed 5 years ago

#3517 closed defect (duplicate)

[landcover] Car park area does not render on top of man_made=pier

Reported by: fluteflute Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

If you look at this car park [1] it has not rendered with a yellow area. I imagine this is because of the man_made=pier that it is on top of.

See also [2]

[1] http://www.openstreetmap.org/browse/way/10519366 [2] http://help.openstreetmap.org/questions/2733/why-are-these-car-parks-refusing-to-render

Change History (3)

comment:1 Changed 8 years ago by Ldp

Your reasoning is correct, but it could be hard to fix this.

I mean, it looks easy, right? Just render parking areas after piers have been rendered? Not so. I can imagine that people map large parking areas as such, and then have little pieces of other landuse (bushes, grass) in that area. That will now render, but not if we render parking areas much later.

Current ordering: landuse (incl. parking) -> water (incl. piers)

comment:2 Changed 5 years ago by math1985

Summary: Car park area does not render on top of man_made=pier[landcover] Car park area does not render on top of man_made=pier

comment:3 Changed 5 years ago by math1985

Resolution: duplicate
Status: newclosed

This is now also being discussed on Github. https://github.com/gravitystorm/openstreetmap-carto/issues/330

Therefore, I will close the issue here.

Note: See TracTickets for help on using tickets.