Opened 9 years ago

Closed 6 years ago

#3531 closed defect (fixed)

Rendering aeroway=taxiway

Reported by: !i! Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

hi,

would be great if aeroway=taxiway could be rendered similar to aeroway=runway (as area but brighter)

Indeed both are indicated as way only objects at http://wiki.openstreetmap.org/wiki/3D_Development#Common_tagging_features but due to BING I guess a lot of people will start mapping it as an area

For example: http://www.openstreetmap.org/?lat=53.80389&lon=12.22517&zoom=15

Change History (5)

comment:1 Changed 9 years ago by pishmishy

aeroway=runway is a tag that's documented as applying to ways and not areas. The rendering should reflect the documentation and not try and preempt how the tag's usage may or may not change.

The change in rendering caused by Changeset #25298 messed up the mapping in some areas where I'd mapped perimeter taxi ways as a continuous loop. Perhaps I was wrong in doing this, I don't know :( My suggestion would be to revert the change and give this some more thought as to what people had intended to represent with existing circular taxi ways.

comment:2 Changed 9 years ago by Ldp

Since many of the aeroway=* tags can and do apply to areas, we handle it as areas by default. This means that once it forms a closed loop, we see it as area. This hadn't been applied to taxiway yet, but now has. You can prevent this by setting area=no.

This doesn't help just the renderer, but any data user that processes your data. It makes it unambiguous just what you intended to represent with that closed way.

PS: Can you supply a link to your example? I'm curious why a closed loop would've rendered as circular way instead of area before, when I would expect we wouldn't have rendered it at all (due to the missing area handling, but closed loops ending up in the polygon table).

comment:4 Changed 9 years ago by Ldp

You can also add area=no instead of splitting it. That makes it clear to data end users what you mean.

comment:5 Changed 6 years ago by math1985

Resolution: fixed
Status: newclosed

This has been resolved in the meanwhile.

Note: See TracTickets for help on using tickets.