Opened 8 years ago

Closed 8 years ago

#3549 closed defect (wontfix)

Buildings no longer rendered after removing them from multipolygon relation (not caused by tagging error)

Reported by: Kurt Krampmeier Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

After removing some buildings from a multipolygon relation that were accidentally added there before with role=outer, they disappeared from the map rendered by Mapnik. Osmarender shows them as expected.

Just compare the attached screenshots or check <http://www.openstreetmap.org/?lat=52.13213&lon=11.60808&zoom=17&layers=M>. The houses with the numbers 51, 52, 54, 13, 15, and 16 are missing in Mapnik. House number 53 was also missing after the mentioned correction but showed up after "touching" the way in JOSM (by adding and removing a node).

History for the modified multipolygon relation (for house number 14): <http://www.openstreetmap.org/browse/relation/1206881/history>

History for the "touched" building (note that nothing has been changed by my edit) <http://www.openstreetmap.org/browse/way/97753125/history>

History for a example of a missing building (note that it has the exact same properties - of course excepting the addr:housenumber key - as the now showing house number 53) <http://www.openstreetmap.org/browse/way/97753202/history>

It looks like Mapnik has some cache, that prevents these buildings from showing up, until they are modified. I think , removing these ways from the relation should also invalidate that cache.

Attachments (2)

rendering_mapnik.png (17.6 KB) - added by Kurt Krampmeier 8 years ago.
rendering_osmarender.png (26.5 KB) - added by Kurt Krampmeier 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Kurt Krampmeier

Attachment: rendering_mapnik.png added

Changed 8 years ago by Kurt Krampmeier

Attachment: rendering_osmarender.png added

comment:1 Changed 8 years ago by steve8@…

Resolution: wontfix
Status: newclosed

Can't understand that. Downloaded data file and rendered locally and it is fine. Nothing wrong with style/render, assume it must be something about cache on the server/website

Note: See TracTickets for help on using tickets.