Opened 8 years ago

Closed 7 years ago

#3563 closed defect (invalid)

Keyboard commands not responsive

Reported by: stevage Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: potlatch2 Version:
Keywords: Cc: mcld

Description

(Andy, potlatch-dev, 4 mar 2011) "I still find the shift key stopping working every now and then, but like Richard I don't have steps to reproduce this one."

Fwiw, I haven't seen this. Does it also happen with other modifiers? Does it stay out of action for the whole session? Any workaround?

Change History (8)

comment:1 Changed 8 years ago by hyrava

Also Ctrl key stops working every now and then but like others I don't have steps to reproduce. It does happen quite randomly, atleast I can't see any logic. I haven't tested if it stays out of action for whole session, because when it happens, I save my work and reload Potlatch2.

comment:2 Changed 8 years ago by Richard

Resolution: fixed
Status: newclosed

No further reports or steps to reproduce, so I'm closing this.

comment:3 Changed 8 years ago by sat@…

Resolution: fixed
Status: closedreopened

This has been happening to me for several months. Right now it happens just about 100% of the time. It may not happen right when I start editing but it's almost guaranteed to eventually pop up (usually within a couple of minutes).

I've tried exiting potlatch2 and restarting but it persists. I've even tried closing my brower (firefox) and reopening and the problem still persists. The only (semi) reliable way I've found to fix it is to exit out of my browser and kill all running instances of flash. Sometimes if I get the problem and I start mashing on my keyboard for a while, it will start working again randomly (usually I just select a way, hold down the shift key and start hitting the delete key repeatedly).

comment:4 Changed 8 years ago by Richard

Not entirely sure what's being reported here.

If it really is the shift key stopping working (i.e. you can't enter upper-case tags, you can't shift-delete a way, you can't shift-click to insert a node), I'd imagine that's a browser/Flash Player-specific issue - in which case it'd be good if you could report what browser/FP version you have.

But if it's the case that (say) you just can't shift-delete a way any more, that's much more likely to be a P2 bug.

If you could install Flash Debug Player, that will help narrow it down. Quite likely that Flash is throwing some sort of exception when this happens: if we know what the exception is then we can try and fix it.

comment:5 Changed 7 years ago by Richard

Resolution: worksforme
Status: reopenedclosed

No further reports and unspecific description so I'm closing this.

comment:6 Changed 7 years ago by mcld

Cc: mcld added
Resolution: worksforme
Status: closedreopened
Summary: Shift key stops workingShift-click to add node to way stops working

I'm getting this happening to me a lot and it's really frustrating. The function that stops working is shift-click to add a node to an existing way. (Shift for capitalisation still works; shift-delete current way still works.)

I am using Firefox 10.0.2 on Ubuntu 11.10, with the standard flash plugin 11.1.102.63-0oneiric1. I use flashblock plugin but potlatch is whitelisted so there's no extra clicking needed to make it appear.

comment:7 Changed 7 years ago by Richard

Summary: Shift-click to add node to way stops workingKeyboard commands not responsive

Retitled - that's actually a completely different issue to shift-clicking. Essentially keypresses aren't being directed to the right 'focus' - Flex 4.5 appears to have changed the behaviour here (sigh).

comment:8 Changed 7 years ago by Richard

Resolution: invalid
Status: reopenedclosed

This'll work better in a separate ticket rather than resurrecting an old one, so am re-closing this and have created #4294.

Note: See TracTickets for help on using tickets.