Opened 8 years ago

Closed 8 years ago

#3573 closed defect (invalid)

Railway platforms render on wrong layer

Reported by: pigsonthewing Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: railway, layer Cc:

Description

Railway platforms with no layer specified are rendering on top of buildings with layer:1

See for example, Small Heath Railway Station, at:

http://www.openstreetmap.org/?lat=52.463756&lon=-1.859454&zoom=18&layers=M

Attachments (2)

SmallHeathStationRender.jpg (9.3 KB) - added by pigsonthewing 8 years ago.
SmallHeathStationRender2.jpg (10.8 KB) - added by pigsonthewing 8 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by Tom Hughes

Component: adminmapnik
Owner: changed from Tom Hughes to mapnik-team@…

Changed 8 years ago by pigsonthewing

Attachment: SmallHeathStationRender.jpg added

comment:2 Changed 8 years ago by pigsonthewing

It's been suggested that this might be worked-around by mapping the platforms as areas (they're currently entered as simple lines)

I'm about to try this, but have attached to this ticket a screen-shot of the current rendering.

comment:3 Changed 8 years ago by pigsonthewing

The problem persist with the platforms as areas; indeed, the areas are "hollow". See second attachment.

Changed 8 years ago by pigsonthewing

comment:4 Changed 8 years ago by Ldp

Don't forget area=yes.

comment:5 Changed 8 years ago by Ldp

Resolution: invalid
Status: newclosed

I see you've added area=yes.

Note: See TracTickets for help on using tickets.