Opened 8 years ago

Closed 5 years ago

#3600 closed enhancement (duplicate)

[amenity-points] Render leisure=water_park

Reported by: pnorman Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc: pnorman, Michael Kleidt, HostedDinner

Description

Currently leisure=water_park is not rendered. As an example, see http://www.openstreetmap.org/?lat=49.233504&lon=-122.890976&zoom=18&layers=M

Attachments (3)

spray_park.diff (813 bytes) - added by pnorman 8 years ago.
proposed rendering
hume.png (78.4 KB) - added by pnorman 8 years ago.
Example showing a spray park, playground, and pool
water_park.gif (42.2 KB) - added by Michael Kleidt 7 years ago.
water park tagged with leiure=park

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by pnorman

Attachment: spray_park.diff added

proposed rendering

Changed 8 years ago by pnorman

Attachment: hume.png added

Example showing a spray park, playground, and pool

comment:1 Changed 8 years ago by pnorman

Cc: pnorman added

My suggested icon would be a triangle with water squirting out. Unfortunately, I don't have the design skills to draw such an icon.

comment:2 Changed 8 years ago by Ldp

Duplicate of the now closed #3101.

pnorman: Please check if tickets on an issue have already been created before creating a new one.

Changed 7 years ago by Michael Kleidt

Attachment: water_park.gif added

water park tagged with leiure=park

comment:3 Changed 7 years ago by Michael Kleidt

In my area all water parks are mapped with leisure=park instead of leisure=water_park. This is mapping for the renderer.

Because leisure=park is looking good (see water_park.gif) and you can see that it is a water park because of the swimming pools, I wouldn't use different colors or an additional icon. Just render leise=water_park the same as leise=park, so we can fix the "mapping for the renderer" issue.

comment:4 Changed 7 years ago by Michael Kleidt

Cc: Michael Kleidt added

comment:5 Changed 6 years ago by HostedDinner

Cc: HostedDinner added

comment:6 Changed 5 years ago by math1985

Summary: Render leisure=water_park[amenity-points] Render leisure=water_park

comment:7 Changed 5 years ago by math1985

Resolution: duplicate
Status: newclosed

This issue is now being discussed on Github: https://github.com/gravitystorm/openstreetmap-carto/issues/370

Therefore, I will close it here.

Note: See TracTickets for help on using tickets.