Opened 8 years ago

Closed 8 years ago

#3609 closed defect (fixed)

When saving a changeset with no description in Potlatch 2, "(none)" should show up for comment on the main site

Reported by: rickmastfan67 Owned by: potlatch-dev@…
Priority: minor Milestone:
Component: website Version:
Keywords: Cc:

Description

I've been noticing this a lot recently that any changeset made with Potlatch 2 with no comment saved shows up as a completely blank line. When this was done with Potlatch 1.4, it would at least save a comment of "(none)".

The reason I consider this a problem is because when you have a buddy use Potlatch 2 and not leave a comment, the "Latest edit" will not give you a link to go view it. It will look like this: [ Latest edit (about 1 hour ago): "" ]. Thus, forcing you to go to their profile, then edits, and then click on the changeset # to view it.

Here is a link to a user that uses both Potlatch 1.4 and 2 to show the blank and "(none)" changesets difference problems: http://www.openstreetmap.org/user/mdroads/edits The blank ones are Potlatch 2, the "(none}" ones are from 1.4.

So, can this be possibly fixed? I would appreciate it.

Change History (3)

comment:1 Changed 8 years ago by Tom Hughes

Component: potlatch2website
Owner: changed from potlatch-dev@… to Tom Hughes
Priority: majorminor

The problem is that PL2 is submitting a comment tag for the changeset with an empty string as the value.

I'll make the website handle that better, but we should fix PL2 to stop it doing that...

comment:2 Changed 8 years ago by Tom Hughes

Owner: changed from Tom Hughes to potlatch-dev@…
Status: newassigned

comment:3 Changed 8 years ago by Tom Hughes

Resolution: fixed
Status: assignedclosed

This is all fixed. Potlatch no longer sets the empty tag, and the site copes with the empty tags for old changesets.

Note: See TracTickets for help on using tickets.