Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#364 closed enhancement (fixed)

[patch] Take heed of access restrictions

Reported by: tom@… Owned by: steve@…
Priority: major Milestone:
Component: osmarender Version:
Keywords: Cc: schuetzm@…

Description

It'd a bit bad that the map currently shows ways with access restrictions without any indication of those restrictions.

For example, there are private footpaths and roads that would sometimes not even be on an Ordinance Survey or A-Z map because they're "access=private". These should either be removed, greyed out, have symbols over them, or some other way of denoting their restrictions.

Attachments (5)

access.diff (10.2 KB) - added by schuetzm@… 11 years ago.
access2.diff (12.3 KB) - added by schuetzm@… 11 years ago.
new version with access=no
access3.diff (12.7 KB) - added by schuetzm@… 11 years ago.
updated against current svn
access4.diff (15.4 KB) - added by schuetzm@… 11 years ago.
new version which always uses criss-cross pattern as suggested by Bob Kåre
access6.diff (20.5 KB) - added by Knut Arne Bjørndal 11 years ago.
New version from Marc Shütz (http://lists.openstreetmap.org/pipermail/tilesathome/2008-May/002166.html)

Download all attachments as: .zip

Change History (16)

comment:1 Changed 11 years ago by schuetzm@…

Cc: schuetzm@… added

The attached patch shows access restrictions for highway=* and amenity=parking in osmarender by hatching over the way or area. The color used indicates the type of restriction:

  • red: private
  • blue: destination
  • green: permissive

comment:2 Changed 11 years ago by schuetzm@…

Summary: Take heed of access restrictions[patch] Take heed of access restrictions

A sample can be seen here (still rendering right now).

Changed 11 years ago by schuetzm@…

Attachment: access.diff added

comment:3 Changed 11 years ago by tom@…

I like it, although the colours could be a little more sublte. Any chance of getting this committed, and ported to the Mapnik stylesheet?

Changed 11 years ago by schuetzm@…

Attachment: access2.diff added

new version with access=no

comment:4 Changed 11 years ago by schuetzm@…

I attached a new version that also takes into account access=no (red criss-cross) and uses lighter colors (currently rerendering the above mentioned area with the patch).

Changed 11 years ago by schuetzm@…

Attachment: access3.diff added

updated against current svn

comment:5 Changed 11 years ago by schuetzm@…

Would someone like to commit this, or are there problems with the patch?

Changed 11 years ago by schuetzm@…

Attachment: access4.diff added

new version which always uses criss-cross pattern as suggested by Bob Kåre

Changed 11 years ago by Knut Arne Bjørndal

Attachment: access6.diff added

comment:6 Changed 11 years ago by Knut Arne Bjørndal

Component: slippy_maposmarender
Priority: criticalmajor
Type: defectenhancement

This latest version looks much better. There are still some glitches with highway areas, but that's a bit of a mess anyway.

I think there's still a smart-linecap mismatch with one of the track styles, could somebody try finding the bug?

I'll be committing the patch shortly.

Sorry for taking so long to give you feedback on the patch.

comment:7 Changed 11 years ago by tom@…

Great, glad to see this patch will go in. One gripe though - this was originally filed against the slippy map, and this patch will fix the Osmarender layer but not the Mapnik layer, which is the default view and so the more important to fix. Please do not mark this as closed until both layers reflect access restrictions.

comment:8 Changed 11 years ago by tom@…

For what it's worth, I've patched an installation I'm working on to show little stop symbols. It's another layer copying the oneway symbol approach:

http://map.oneplanetsutton.org/?zoom=3&lat=51.39445&lon=-0.17174&layers=B0FF

and

http://map.oneplanetsutton.org/?zoom=4&lat=51.39098&lon=-0.15713&layers=B0FF

comment:9 in reply to:  7 Changed 11 years ago by Knut Arne Bjørndal

Replying to tom@acrewoods.net:

Great, glad to see this patch will go in. One gripe though - this was originally filed against the slippy map, and this patch will fix the Osmarender layer but not the Mapnik layer, which is the default view and so the more important to fix. Please do not mark this as closed until both layers reflect access restrictions.

I changed the component because it's not a bug in the slippy map, it's a map stylesheet feature request.

I think the cleanest way to go forward with this is to iron out the bugs in the osmarender patch, then change the component to mapnik and let somebody else handle that. Either that or make a separate ticket against mapnik.

comment:10 Changed 11 years ago by Knut Arne Bjørndal

Resolution: fixed
Status: newclosed

This was commited just around the Quickborn client update, in r7963.

Tom: I think you should file a separate ticket against mapnik (and refer to this).

comment:11 Changed 11 years ago by tom@…

Thanks for the suggestions and for the Osmarender fix. There isn't a mapnik component in this trac installation, which is why I filed it against slippy_map originally. It's obviously not something for Mapnik's own trac.

Can you advise on the best component to file it against?

Note: See TracTickets for help on using tickets.