Opened 8 years ago

Closed 8 years ago

#3659 closed defect (invalid)

keep getting "Couldn't load the map"

Reported by: alexandros.papadopoulos@… Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version:
Keywords: Cc:

Description

When editing the map with Potlatch2, panning with the arrow keys invariably results in a "Couldn't load the map" error. Once that happens, it's impossible to zoom in/out or pan in any direction. The only way out is to reload the entire page to force Potlatch2 to reload.

Using Adobe Flash 10.2.153.1 and having this issue both on Firefox 4 (Windows & Linux) and IE8.

Please note that this happens in desolate areas of the map (no waypoints or trackpoints whatsoever), so it doesn't appear to be an issue of trying to display too much information.

Disabling the background maps (background = none) does not make this any better.

Attaching screenshot of this occuring in an otherwise empty area of the map.

Note: I always activate the "show mouse latitude/longitude" option and use that as a guide to reach the desired area.

Attachments (1)

couldntloaddata.png (95.6 KB) - added by alexandros.papadopoulos@… 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by alexandros.papadopoulos@…

Attachment: couldntloaddata.png added

comment:1 Changed 8 years ago by Richard

I can't reproduce this at all, even at the location quoted in your screenshot. Suggest that you ask on IRC and wait around until there's a sysadmin available (with access to the logs) who can track whether or not your requests are actually getting through to the server. There's no certainty that this is an issue with P2: it could be with the API, Flash Player, your network connection, who knows!

comment:2 Changed 8 years ago by alexandros.papadopoulos@…

Resolution: invalid
Status: newclosed

Hrmf. Got home, uploaded the remaining waypoints on a brand new GPX and it has been working for hours now without a hiccup! Contrast that with the last 24 hours' struggling to get anything done with crashes/errors from two computers and two locations.

Perhaps it was something in the particular GPX file that upset it, although I can't think what that may have been.

Or I'm just doing something stupid.

In any case, seems to be ok now. Sorry for the false alarm.

Note: See TracTickets for help on using tickets.