Opened 8 years ago

Closed 8 years ago

Last modified 3 years ago

#3678 closed defect (fixed)

Mapnik not respecting layer tags in the trunk family when bridges are involved at interchanges

Reported by: rickmastfan67 Owned by: mapnik-team@…
Priority: critical Milestone:
Component: mapnik Version:
Keywords: trunk trunk_link bridge layer Cc:

Description

Whenever there is a trunk bridge rendered over a trunk_link bridge (or vice versa), the layer tags are not respected at all. An example would be here: http://www.openstreetmap.org/?lat=41.887203&lon=-87.614107&zoom=18&layers=M

You expect that at least in it's own family that Mapnik would respect the layer tags when rendering trunk* bridges, because this looks really ugly. It looks like all the ways are intersecting each other which is obviously not the case here since it's an elevated interchange.

Heck, Mapnik respects motorway/motorway_link bridges when layer/bridge tags are used and they cross each other. Why not trunk/trunk_link as well?

So, please get this fixed asap. At least osmarender can do this correctly.

Change History (3)

comment:1 Changed 8 years ago by JDub

This problem looks similar to ticket #3250. Maybe they're caused by the same error?

comment:2 Changed 8 years ago by Ldp

There are lots of tickets that point out these layering issues. Lots of duplicates too.

In short: we're well aware of these issues, but haven't moved entirely forward due to several reasons. Stylesheet complexity and server performance being the most prominent ones.

comment:3 Changed 8 years ago by Ldp

Resolution: fixed
Status: newclosed

(In r26009)

Note: See TracTickets for help on using tickets.