Opened 8 years ago

Closed 8 years ago

#3687 closed defect (duplicate)

I18N not working in P2 (custom instance)

Reported by: Nop Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version: 2.0
Keywords: i18n Cc:

Description

P2 does not switch to assigned locale, but shows english/broken text.

I copied the locale/ subdir into the P2 folder and set fo.addVariable("locale", "de_DE") using osm.org as a template.

P2 remains partially in English, partially broken: The GPS data menu is filled with [Object object]. Tried it with the version from random.dev... and osm.org. g07a59e4. Browser is FF, link to P2 instance is http://www.wanderreitkarte.de/edit/edit.php?lon=11.3933&lat=49.6757&zoom=18

Change History (6)

comment:1 Changed 8 years ago by Andy Allan

I see "GPS-Daten" "Meine Tracks" and "Clear" on your instance, as I would expect.

Also only some parts of the interface have been i18n-ised, so I would expect much of it to be in English. Let's use this ticket to figure out why you are seeing [Object object] and I am not. Do you see the same thing on a different browser / machine? Is it a caching issue (try flushing your flash cache)?

comment:2 Changed 8 years ago by Andy Allan

Thinking about it, I think this might be the "default locale" issue, since it's likely that Nop's flash player will have de_DE as its default in the same way that mine has en_US.

There's a bug in the i18n library where it thinks it has loaded the bundle for the default_locale and never actually requests it. This would manifest itself as button labels falling back to english and the GPS menu screwing up.

comment:3 Changed 8 years ago by Nop

If forgot to mention: Yes, I cleared the browser cache and the flash cache, no difference.

To test the theory above, I set the locale to "fr_FR", but it does not change anything, remains english/[object]. So I assume it is not a confusion with the default locale.

comment:4 in reply to:  1 Changed 8 years ago by Nop

Replying to Andy Allan:

I see "GPS-Daten" "Meine Tracks" and "Clear" on your instance, as I would expect.

Also only some parts of the interface have been i18n-ised, so I would expect much of it to be in English. Let's use this ticket to figure out why you are seeing [Object object] and I am not. Do you see the same thing on a different browser / machine? Is it a caching issue (try flushing your flash cache)?

Any ideas about possible reasons why I only see the english version? I even tried IE with the same result.

However, I noted that for a split second, GPS-Data is shown, but then it is overwritten by [object].

comment:5 Changed 8 years ago by Nop

I had a friend check the P2 instance independently on another machine. It appears english/broken there too.

I have no idea why Andy saw a German translation.

comment:6 Changed 8 years ago by Andy Allan

Resolution: duplicate
Status: newclosed

Duplicate of #3674

Note: See TracTickets for help on using tickets.