Opened 13 years ago

Closed 12 years ago

#369 closed defect (fixed)

Moving tagged nodes in the applet looses the tags

Reported by: pere@… Owned by: writetodan@…
Priority: major Milestone:
Component: applet Version:
Keywords: Cc: Tom Hughes

Description

I ran into a problem with the applet the other day, and was able to verify it today. I've tagged a few nodes in josm, and used the applet to move them into the correct location. First I moved the royal castle in Oslo, and next it was a cinema. When the node is moved in the applet, josm is no longer able to find any tags on the node. I checked in the applet after the move if the tags were still present. They were there. But when I looked at the same map area using jsom later, the tags were gone.

This make it very dangerous to move nodes in the applet.

Change History (3)

comment:1 Changed 13 years ago by Tom Hughes

Cc: Tom Hughes added

If the output on the Java console accurately reflects the PUT request that is sent to the server then the problem is that the wrong format seems to be being used for the tags in the XML that is sent - see this example:

Trying to PUT xml "<osm><node tags="{amenity=place_of_worship, name=St Catherine & St Paul, created_by=JOSM, denomination=church_of_england}" lon="-0.01198750129697146" lat="51.76259652124846" id="18338210" /></osm>" to URL http://www.openstreetmap.org/api/0.3/node/18338210

comment:2 Changed 13 years ago by writetodan@…

Owner: changed from steve@… to writetodan@…

confirmed from code, .../client/Adapter.java, culprit:

String xml = "<osm><node tags=\"" + node.getTags() + "\" lon=\""

+ node.coor.lon + "\" lat=\"" + node.coor.lat + "\" id=\"" + node.id + "\" /></osm>";

... the tags format we're seeing in the request is default Hashtable toString() implementation. am checking in a load of other fixes, i'll add this one in as well once i have tested.

comment:3 Changed 12 years ago by writetodan@…

Resolution: fixed
Status: newclosed

fix deployed to www

Note: See TracTickets for help on using tickets.