Opened 8 years ago

Closed 5 years ago

#3705 closed defect (fixed)

[placenames] Font size of label on "place=city" on a multipolygon not the same as the size of a city node?

Reported by: spod Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc:

Description

I have created a multipolygon with a "place=city" tag (and no other complicating 'boundary' tags), but the label is not rendered the same size font as a the label of a node tagged "place=city". Shouldn't the labels be the same size font, because they are both "place=city"? See: A city node: http://www.openstreetmap.org/browse/node/1245513960 A city multipolygon: http://www.openstreetmap.org/browse/relation/1553544

(Note: Those are both relatively new objects, so they may not be rendered at different zoom levels yet, because the mapnik render queue is full 24 hours a day at the moment, so they never get rendered)

Mapnik appears to be rendering the label in a smaller sized font, similar to that used for the 'centre' of administrative boundaries. I suspect that mapnik is also applying a different zoom-level filter for the 2 objects so the multipolygon label doesn't appear at the same zoom level as node cities.

Change History (5)

comment:1 Changed 8 years ago by spod

See also: #2090

comment:2 Changed 5 years ago by math1985

Summary: Font size of label on "place=city" on a multipolygon not the same as the size of a city node?[placenames] Font size of label on "place=city" on a multipolygon not the same as the size of a city node?

comment:3 Changed 5 years ago by math1985

Resolution: duplicate
Status: newclosed

Names on city multipolygons are no longer rendered, so I will close this issue.

comment:4 Changed 5 years ago by math1985

Resolution: duplicate
Status: closedreopened

comment:5 Changed 5 years ago by math1985

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.