Ticket #3738 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Glitch in focus handling for tabs in simple mode

Reported by: Nop Owned by: potlatch-dev@…
Priority: major Milestone:
Component: potlatch2 Version: 2.0
Keywords: Cc:

Description

When you select any tab but the first one in simple mode and then select a different object on the map, the tab jumps back to the first one. But the previously selected tab seems to keep an invisible focus, when you select it again, nothing happens - probably it believes that it is already selected. When you switch to another tab and back, it resumes working.

The active tab should not be reset when switching objects in the map. This would help with editing/chekcing information on similar objects.

If the tab is reset to the first tab on object change, all other tabs should work when clicked the first time.

Version g106bbd1

Change History

comment:1 Changed 3 years ago by Richard

  • Status changed from new to closed
  • Resolution set to fixed

This is a dupe of a SuperTabNavigator? problem we fixed a while ago. (And we've since dropped SuperTabNavigator? anyway.)

Note: See TracTickets for help on using tickets.