Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#3754 closed defect (wontfix)

No search on wince

Reported by: messpert Owned by: nroets@…
Priority: minor Milestone:
Component: gosmore Version:
Keywords: search inaccessible Cc: law_ence.dev@…

Description

The search box is not active on wince gosmore, or is overlaid by the zoom-in "+" button. Adjusting the button size does not cure the problem. This renders search inaccessible which makes gosmore largely useless.

This happened on changing from the 26-102010 version (which worked) to the new 21-2-2011 version.

gosmore.log.txt seems to contain nothing of any relevance. Target system is WinCE Core 5.0 with small screen.

Attachments (1)

patch.diff (16.4 KB) - added by openstreetmap@… 8 years ago.
Better searching

Download all attachments as: .zip

Change History (7)

comment:1 Changed 8 years ago by messpert

I should have added that the satnav has 3.5inch colour 320x240 TFT display touch panel, and 64MB ram.

comment:2 Changed 8 years ago by messpert

Priority: criticalminor

I have now discovered that moving over to the far right of the search box works. It seems that the "+" button overlays most of the search box, and adjusting the button size as above does not help.

I will adjust the priority to minor, although until one discovers the way to get in, it is still "critical" :-)

comment:3 Changed 8 years ago by messpert

Priority: minorcritical

The problem is back, so I am restoring the priority to critical. I *think* that I accidentally ran the old version when I reported that it worked again.

So this is a show stopper on Wince, at least on the version here.

Changed 8 years ago by openstreetmap@…

Attachment: patch.diff added

Better searching

comment:4 Changed 8 years ago by openstreetmap@…

Priority: criticalminor
Resolution: wontfix
Status: newclosed

I've never seen the problem as you describe it.

I know that searching is a real pain on devices without soft keyboards. Then you need to set Keyboard=1 and that keyboard obscures search results and cannot be hidden. I'm attaching a patch made by burebista that alleviates it somewhat.

I don't think it worthwhile improving the WinCE port. Android devices are now cheaper, with better hardware (compass, accelerometers and GPU), more user friendly (esp. multitasking) and easier to program and debug.

comment:5 Changed 8 years ago by messpert

It's a WinCE Core 5.0 if that makes any difference. And the previous version of gosmore worked fine, so it must be a side effect of some change?

This has a soft keyboard. I would expect it to work if I could activate search. So far as I can determine, it is a simple matter of the button not being accessible.

If I set Keyboard=1 on the previous version, then the keyboard completely vanished.

I think that we may be at cross purposes here. Indeed, on the older gosmore, the soft keyboard did restrict the number of search results accessible. Changing the search spacing helped a bit.

But that is not *this* bug. This bug is the complete inability to activate seacrh at all. Apparently no button at all. Surely it is must be something trivial, easy to fix? At least to get back to where the previous version was. I agree that sorting out the search layout to avoid the keyboard obsuring results would be a bit more of an effort.

Thanks for the reply and all the work.

I still think it is critical if not a blocker for those of us with wince sat navs.

comment:6 Changed 6 years ago by dmgroom

Just in case anyone else is having the same problem, then try:

set Keyboard=1 ; then exit Gosmore ; then restart Gosmore

Note: See TracTickets for help on using tickets.