Opened 8 years ago

Closed 5 years ago

#3778 closed defect (fixed)

Label for "highway=service | service=driveway" tagged with name is rendered at z15 where driveway isn't

Reported by: Jonas Häggqvist Owned by: mapnik-team@…
Priority: minor Milestone:
Component: mapnik Version:
Keywords: Cc: kay_D

Description

At z15, highway=service,service=driveway isn't rendered. However, if the way is tagged with a name, the label is rendered. This ends up looking rather silly.

Example: http://osm.org/go/0Si1qd7T--

Change History (5)

comment:1 Changed 8 years ago by Jonas Häggqvist

Component: adminmapnik
Owner: changed from Tom Hughes to mapnik-team@…

comment:2 Changed 8 years ago by rickmastfan67

Summary: Label for service=driveway tagged with name is rendered at z15 where driveway isn'tLabel for "highway=service | service=driveway" tagged with name is rendered at z15 where driveway isn't

I just noticed this as well after I tagged a few highway=service,service=driveway that already had names.

http://www.openstreetmap.org/?lat=40.58794&lon=-80.03299&zoom=15&layers=M

But they aren't as noticeable like the example rasher gave.

And here's the ways in question:

http://www.openstreetmap.org/browse/way/11722116 & http://www.openstreetmap.org/browse/way/11722121

comment:4 Changed 6 years ago by Jonas Häggqvist

This issue still exists.

comment:5 Changed 5 years ago by math1985

Resolution: fixed
Status: newclosed

It seems that this issue has been resolved in the meanwhile.

Note: See TracTickets for help on using tickets.