Opened 8 years ago

Closed 5 years ago

#3794 closed defect (fixed)

Not Rendering Pipelines (But Their Names)

Reported by: LetzFetz Owned by: mapnik-team@…
Priority: major Milestone:
Component: mapnik Version:
Keywords: Cc: LetzFetz

Description

Mapnik renders tiles without pipelines but the names of pipelines. It's confusing to see names floating in the map without any object they could belong to. An example: http://www.openstreetmap.org/?lat=50.80735&lon=6.13086&zoom=17&layers=M Looking at this area using JOSM you see 5 pipelines. The rendered tiles show only their names.

Change History (3)

comment:1 Changed 7 years ago by gerdami

Yes, please add a Mapnik rendition for man_made=pipeline.

comment:2 Changed 7 years ago by stefanct

Summary: Not Rendering Pipelines But Their NamesNot Rendering Pipelines (But Their Names)

While the issue of the rendered names is a problem (of its own), the missing rendering of pipelines is the major problem here. They can help orientation a lot especially if they are mounted on bridges, because this creates a widely observable object. For an example of such a bridge see here. The 'location' of a pipeline can be tagged to be 'overground' and to be a 'bridge=yes', so it is pretty clear to derive the situations when it should be drawn. I do not have an idea how it should be rendered, but there are some suggestions in the wiki and TBH i do not care too much, as long as it IS rendered :)

comment:3 Changed 5 years ago by pnorman

Resolution: fixed
Status: newclosed

The place to report issues with openstreetmap-carto, the "standard" style on openstreetmap.org is on its issue tracker. The old Mapnik XML based stylesheets have been retired.

The catch-alls that were the cause of many of these names have been removed. If there is a desire to render a new feature, an issue should be created on the issue tracker for the new stylesheet.

Note: See TracTickets for help on using tickets.