Opened 8 years ago

Closed 8 years ago

#3805 closed enhancement (fixed)

edit: remote control: please download object from browse pages (WAS: does not download correct BBOX around node)

Reported by: skyper Owned by: Tom Hughes
Priority: minor Milestone:
Component: website Version:
Keywords: edit BBOX remote control object Cc: skyper

Description

Please try to download http://www.openstreetmap.org/browse/node/1221699431

with JOSM remote control.

The BBOX does not even have the node inside!

A feature would be, if the object would be selected after download.

Thanks

Change History (7)

comment:1 Changed 8 years ago by Tom Hughes

Resolution: invalid
Status: newclosed

JOSM bug should be reported in the JOSM bug tracker at http://josm.openstreetmap.de/.

comment:2 in reply to:  1 Changed 8 years ago by skyper

Cc: skyper added
Resolution: invalid
Status: closedreopened

Replying to TomH:

JOSM bug should be reported in the JOSM bug tracker at http://josm.openstreetmap.de/.

No, it is a problem with the provided link on the website[[BR]] Just use edit -> remote control on the linked page.

Now it changed a bit, but the BBOX is to big and JOSM das not download the data.

comment:3 Changed 8 years ago by skyper

Should remote control not just download the object and not a BBOX in this case ?

Same counts for ways and relations.

At least selected the object in JOSM when downloading a BBOX.

Stange, something is changing right now, but for relations it does not work, for ways and nodes it seems to work again.

comment:4 Changed 8 years ago by Tom Hughes

The problem is that you are expecting the edit tab on the browse pages to edit the object you are browsing, but it has never been designed to do that.

What it does, as it does on all pages except the map and edit views, is to edit the last area you viewed on the map.

comment:5 in reply to:  4 Changed 8 years ago by skyper

Keywords: object added
Priority: minormajor
Summary: edit: remote control does not download correct BBOX around nodeedit: remote control: please download object from browse pages (WAS: does not download correct BBOX around node)
Type: defectenhancement

Replying to TomH:

The problem is that you are expecting the edit tab on the browse pages to edit the object you are browsing, but it has never been designed to do that.

What it does, as it does on all pages except the map and edit views, is to edit the last area you viewed on the map.

This behaviour is very unexpected.

Please, is it possible to only download the object if edit (with remote control) is selected from an browse page. Thanks

By the way, I also wonder why I am send to the map, but that seems to be connected to the BBOX. It is also not needed and I do not want to download more data than really needed.

Please, let the action (remote control) be done in the backround and just stay on the browse page.

comment:6 Changed 8 years ago by Tom Hughes

Priority: majorminor

No, I won't be changing the edit tab do do that as that would mean it's behaviour was different to the view link.

In fact I have already disabled the edit tab when not on the map view, though that hasn't been deployed yet.

What I do intend to do is to add an edit link under the map on that page, to mirror the view link which is already there.

comment:7 Changed 8 years ago by Tom Hughes

Resolution: fixed
Status: reopenedclosed

The fix I described in my previous comment is now in the process of being deployed.

Note: See TracTickets for help on using tickets.