Ticket #3811 (closed enhancement: duplicate)

Opened 3 years ago

Last modified 3 years ago

Potlatch 2 "R" won't copy tags from node to way

Reported by: bryce2@… Owned by: potlatch-dev@…
Priority: minor Milestone: Wishlist
Component: potlatch2 Version: 2.0
Keywords: Cc:

Description

A frequent use case for me:

Find a node that represents a building Draw the building outline Copy the tags to the way Delete the node

With JOSM I can readily copy the tags. Potlatch will only repeat tags from a prior WAY, not a prior NODE.


I previously thought the entire feature was broken: apparently I only ever tried it on nodes:  http://trac.openstreetmap.org/ticket/3809

Change History

comment:1 follow-up: ↓ 3 Changed 3 years ago by stevage

  • Type changed from defect to enhancement

To clarify, Potlatch can repeat way tags to ways, or node tags to nodes. It doesn't repeat node tags to ways. I'm not sure it would be good behaviour to do so with the standard "R" shortcut - in my case, that would mean I would end up with "highway=turning_circle" on streets.

So, perhaps this is an enhancement for a shift+R to allow repeating of tags from the "wrong type".

comment:2 Changed 3 years ago by bryce2@…

For reference, JOSM is pretty functional here. I can copy nodes/tags, and also get an indication of which tags differ.

That's great if I'm trying to change a street name on a dozen connected ways. I get to instantly see what tags are consistent, and what tags need greater inspection.

Shift-R seems fine. Or make the feature part of an "advanced mode" only discovered by advanced users.

comment:3 in reply to: ↑ 1 Changed 3 years ago by DaveF

Replying to stevage:

that would mean I would end up with "highway=turning_circle" on streets.

Only if you had the whole way selected; if you selected a single on that way it would work.

comment:4 Changed 3 years ago by Richard

  • Status changed from new to closed
  • Resolution set to duplicate

Pretty much a duplicate of #3980.

Note: See TracTickets for help on using tickets.